Recently I have starting getting a lot of failed prints stopping with error in g-code. I use fusion 360 to make the model, Simplify 3D to slice it. Today I updated the firmware in hopes that it would solve the problem. The only change is that it throws the error at print start and not mid print, which is an improvement, but stil...

This is the line it say conain an error : G1 X128.220 Y14.720 F3500

This is the few lines ahead and after the offending line.
G92 E0
G1 E-1.0000 F1800
; inner perimeter
G1 X128.220 Y14.720 F3500
G1 E0.0000 F1800
G92 E0

Any suggestions as to how I fix this?

October 18, 2017

Marius Marius
Beginner
7 posts

10 replies


There is nothing wrong with those lines that I can see. An exact error message would help, a downloadable gcode file would be even better. I assume you have a CraftBot.

October 18, 2017

psanyi psanyi
Exalted
939 posts

The message displayed in the display was:

Error in G-Code

Line 28779


October 18, 2017

Marius Marius
Beginner
7 posts

Can you email the gcode to info@craftbot.nl ?
Maybe the factory file as well from S3D?

As you updated the firmware I assume you have a CraftBot, as Psanyi asked.
And which CraftBot?





October 18, 2017

Bart ter Haar Bart ter Haar
Service partner
1641 posts

I have Craftbot Plus, about 6 months old. Same problem before and after yesterdays firmware update. I'll send you the files once I get home.

October 19, 2017

Marius Marius
Beginner
7 posts

Hi Marius, I checked the Gcode of the Satsubako.gcode and found strange values:

Error in G-Code


So that's were the CB is tripping over I suppose.
The first line that's not as I know is this:

G1 X192.766 y15.128 E21.22:1
So suddenly a low case "y" and the ":1"

I have no idea why S3D is generating that, as your settings for the process seem to be ok.

The only thing I can think of that your regional settings are not understood well. Maybe set them to English / international. Also maybe, above a certain size of the gcode, it's changing the exponentiational values or so.

But to me it seems it's a S3D problem and not a Firmware / CB problem because of these strange generated vales.

October 21, 2017

Bart ter Haar Bart ter Haar
Service partner
1641 posts

Nah, it seems just random garbage to me. There is no regional settings, where you use CAN (#18) instead of X (#58). Something flips those bits randomly, so you get y from Y or CAN from X by flipping one bit. An interesting test would be to make the same gcode twice and compare. Or maybe it is good when generated, but corrupted while copying.

October 22, 2017

psanyi psanyi
Exalted
939 posts

Are you calling me carbage again ;-)

Anyway: when I slice the factory file with S3D (so that's the stl's and the process) I got no error. The gcode Marius provided is causing an error when loading it in CraftWare.

Tip: you don't have to print the gcode to find out it has an error: just load the gcode in CraftWare.

October 22, 2017

Bart ter Haar Bart ter Haar
Service partner
1641 posts

A update from OP.

This weekend the USB stick that came with the machine died. It can no longer be read or writen to. My Mac is also unable to reformat it. So this might be a case of corruption on the usb stick. I'll see if I can find another one, and try again.

Thank you for checking.

October 23, 2017

Marius Marius
Beginner
7 posts

It sounds odd to be just an USB corruption, it sounds more like a version error, what version of Simplify3d are you running? its in a MAC? have you tryied with another slicer??

Im running Simplify3d V3.1.1 on a mid-2012 Mac, and never experience any kind of issue like that, check on another slicer if you have the same issue, if the problems continue send me the stl, ill sliced and send it back to you to see if happends the same.

*Note: i have used like 5 diferent types of usb sticks, and corruption can happends, but most of the time the printer wont read a corrupted pen drive.

October 24, 2017

Joe Medina Joe Medina
Friendly
184 posts

Hi all,
Please refer to my other post in the same topic:
Other post

Cheers,

March 22, 2019

Colonevich Colonevich
Beginner
4 posts
To start a discussion or reply to a post please Login or Create an account.