Okay, so I am new to Craftware but still. I am having the following issues: Bare in mind that I am only testing materials at this point with test cubes and flat rectangulars so I do not think it is the stl file, which I drew up myself in Catia V5.

1- Sometimes it does not draw the skirt
2- It will not do a warm up fill
3- I made a 25 mm cube that with a square hole in the middle (3 mm walls) - It fills in the entire cube or only makes a 2 walled hollow cube if I uncheck infill and or top/bottom shell - Okay, I just went back to recreate the crime scene and take some screen shots and now it works.
4- For some reason, it keeps selecting T0 head. I have it unchecked and it still outputs the Gcode for T0. I even changed the temperature and kept it unchecked and it still output T0 with the new temperature.
I know I am just missing somethings but maybe some of you have encountered some of these issues as well.
Any help would be appreciated.

January 12, 2019

Wayne95 Wayne95
Beginner
9 posts

5 replies


Okay, I solved one of my problems. I had skirt set to head 1 in the extruder tab. I ignored that tab because I am only using one extruder.

January 12, 2019

Wayne95 Wayne95
Beginner
9 posts

Hi Wayne,

1- Yeah, that head usage for skirt/brim/raft is not clear. In 1.21 it is now automatically selected in easy slice mode. Then going to expert mode it can be adjusted.

2- Can you share a photo as an example for this? Would like to see what could be wrong.

4- This one is a bit foggy for me. Is "it keeps selecting T0 head" about the temperature or the object?

Regards,
Norbert

January 15, 2019

NorbertF NorbertF
Admin
132 posts

Thanks Norbert,
2- I think I may be confused, I thought this was a pre extrusion. I was looking for filament to come out the nozzle.
4- i did not know about selecting the left or right head before slicing. I figured putting one head to 0 temp would "turn it off". This, I think, has solved this problem. I have changed my graphics to Lime green for left and Red for right so it makes it easier to visualize which tool is being used.

January 15, 2019

Wayne95 Wayne95
Beginner
9 posts

2- Ah yes, now I know what you meant. The pre-extrusion is under "GCode" tab called "Startup Extrusion". The "Warmup Fill" draws a bit of the inside of an island before drawing its perimeter to ensure constant filament flow on the perimeters.

4- A head is not heated when you don't use it, you don't need to "force turn off" it. If heating gcode for T0 is there, then something is printed with it. (In object selection mode something is set to "Head 1")
Also, I don't understand how heating gcode could be generated if you uncheck it. Setting temp to "0" is of course an alternative, but unchecking it will disable gcode generation for it.
Could you send some examples of this?
May be some weird behavior that I can't reproduce.

Regards,
Norbert

January 15, 2019

NorbertF NorbertF
Admin
132 posts

Thanks again Norbert,

4- Once I figured out how to select head 1 and 2 I haven't had the issue. I think Craftware got confused when I checked head 2 and set a temperature but head 1 was selected (by default). Sorry I'm at work and can't remember where all the features are for exact reference.

January 15, 2019

Wayne95 Wayne95
Beginner
9 posts
To start a discussion or reply to a post please Login or Create an account.